Browser Technical Information

Canvas and other applications highly recommend using the newest version of whatever browser you are using (as of Aug 27, 2020):

  • Chrome 84 and 85
  • Firefox 79 and 80 (Extended Releases are not supported in Canvas)
  • Internet Explorer 11 - IE 11 is not supported after Aug 3, 2019.
  • Edge 84 and 85
  • Safari 12 and 13 (Macintosh only)

Unsure if you meet the minimum requirements? Use detectmybrowser.com for assistance.

For more detailed information about Canvas browser requirements, visit the Technical Information page in the Alamo Colleges District Canvas Student Quick Guide.

0 Comments

Add your comment

E-Mail me when someone replies to this comment